D100 Radio Broadcast Outage

Minor incident D100 Radio Broadcast
1 day, 18 hours, 1 minute, 5 seconds

Updates

Resolved

Service is back up.

July 19, 2020 · 11:20 AM EST
Issue

D100 Radio is currently unavailable on certain directories, our team is investigating.

July 17, 2020 · 05:19 PM EST

← Back